<!doctype html >
<!--[if IE 8]><html
class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]><html
class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--><html
lang="en-US"> <!--<![endif]--><head><title>President mourns national hero, Moyo | The Zimbabwe Daily</title><meta
charset="UTF-8" /><meta
name="viewport" content="width=device-width, initial-scale=1.0"><link
rel="pingback" href="https://thezimbabwedaily.com/xmlrpc.php" /><meta
name="google-site-verification" content="gzJyc4VwMkqdXXW4hAcgsNAdfKqqCXREbv4j2ienkGw" /><meta
name="msvalidate.01" content="BE4257D79361D9984A0EBBE76AD147B8" /><link
rel="manifest" href="https://thezimbabwedaily.com/pwa-manifest.json"><link
rel="apple-touch-icon-precomposed" sizes="192x192" href="https://thezimbabwedaily.com/android-chrome-192x192.png?v=yyQPxKaq9d"><link
rel='dns-prefetch' href='//www.googletagmanager.com' /><link
rel='dns-prefetch' href='//s.w.org' /><link
rel='dns-prefetch' href='//i0.wp.com' /><link
rel='dns-prefetch' href='//i1.wp.com' /><link
rel='dns-prefetch' href='//i2.wp.com' /><link
rel='dns-prefetch' href='//c0.wp.com' /><link
rel='dns-prefetch' href='//widgets.wp.com' /><link
rel='dns-prefetch' href='//s0.wp.com' /><link
rel='dns-prefetch' href='//0.gravatar.com' /><link
rel='dns-prefetch' href='//1.gravatar.com' /><link
rel='dns-prefetch' href='//2.gravatar.com' /><link
rel="alternate" type="application/rss+xml" title="The Zimbabwe Daily &raquo; Feed" href="https://thezimbabwedaily.com/feed" /><link
rel="alternate" type="application/rss+xml" title="The Zimbabwe Daily &raquo; Comments Feed" href="https://thezimbabwedaily.com/comments/feed" /><link
rel="alternate" type="application/rss+xml" title="The Zimbabwe Daily &raquo; President mourns national hero, Moyo Comments Feed" href="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html/feed" /><link
rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.6/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify}</style><link
rel='stylesheet' id='wpo_min-header-3-css'  href='https://thezimbabwedaily.com/wp-content/cache/wpo-minify/1608381520/assets/wpo-minify-header-48a7390d.min.css' type='text/css' media='all' /><link
rel='stylesheet' id='wpo_min-header-4-css'  href='https://thezimbabwedaily.com/wp-content/cache/wpo-minify/1608381520/assets/wpo-minify-header-8cec0ef6.min.css' type='text/css' media='all, print' /><link
rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/9.2.1/_inc/social-logos/social-logos.min.css' type='text/css' media='all' /><link
rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/9.2.1/css/jetpack.css' type='text/css' media='all' /> <script>!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://steadfastsystem.com/v2/0/kva2ll4NKqn2iduu2xj7TYqLHoN3tZxpuKwDbr7-QnyL2IdKoPFp5cxeyFq5hqg4kihVH4neYpE8qPlp23MfFgGZoFlNIyIKtYbbC7zcy9VKCRIQLWfvggtwwfTqHXBnieSwxcCcw",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function")</script><script type='text/javascript' src='https://c0.wp.com/c/5.6/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.6/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script> <script type='text/javascript' id='jetpack_related-posts-js-extra'>var related_posts_js_options={"post_heading":"h4"}</script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.2.1/_inc/build/related-posts/related-posts.min.js' id='jetpack_related-posts-js'></script> <link
rel="https://api.w.org/" href="https://thezimbabwedaily.com/wp-json/" /><link
rel="alternate" type="application/json" href="https://thezimbabwedaily.com/wp-json/wp/v2/posts/529731" /><link
rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thezimbabwedaily.com/xmlrpc.php?rsd" /><link
rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thezimbabwedaily.com/wp-includes/wlwmanifest.xml" /><meta
name="generator" content="WordPress 5.6" /><link
rel="canonical" href="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html" /><link
rel='shortlink' href='https://wp.me/p5aQUY-2dO3' /><link
rel="alternate" type="application/json+oembed" href="https://thezimbabwedaily.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthezimbabwedaily.com%2Fnews%2F529731-president-mourns-national-hero-moyo.html" /><link
rel="alternate" type="text/xml+oembed" href="https://thezimbabwedaily.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthezimbabwedaily.com%2Fnews%2F529731-president-mourns-national-hero-moyo.html&#038;format=xml" /><style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]--> <script>window.tdb_globals={"wpRestNonce":"f99bff0749","wpRestUrl":"https:\/\/thezimbabwedaily.com\/wp-json\/","permalinkStructure":"\/%category%\/%post_id%-%postname%.html","isAjax":!1,"isAdminBarShowing":!1,"autoloadScrollPercent":50,"postAutoloadStatus":"on","origPostEditUrl":null}</script> <script>window.tdwGlobal={"adminUrl":"https:\/\/thezimbabwedaily.com\/wp-admin\/","wpRestNonce":"f99bff0749","wpRestUrl":"https:\/\/thezimbabwedaily.com\/wp-json\/","permalinkStructure":"\/%category%\/%post_id%-%postname%.html"}</script> <meta
name="generator" content="Feed to Post 3.13.4" /> <script type="application/ld+json" class="saswp-schema-markup-output">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</script> <style type="text/css">html:not(.jetpack-lazy-images-js-enabled):not(.js) .jetpack-lazy-image{display:none}</style> <script>document.documentElement.classList.add('jetpack-lazy-images-js-enabled')</script> <link
rel="amphtml" href="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html?amp"><meta
property="og:type" content="article" /><meta
property="og:title" content="President mourns national hero, Moyo" /><meta
property="og:url" content="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html" /><meta
property="og:description" content="Joseph Madzimure, Harare BureauPresident Mnangagwa has described the late Brigadier-General Collin Moyo (Retired), who died last Friday and was buried yesterday at the National Heroes Acre in Harar…" /><meta
property="article:published_time" content="2021-01-12T22:07:19+00:00" /><meta
property="article:modified_time" content="2021-01-12T23:09:20+00:00" /><meta
property="og:site_name" content="The Zimbabwe Daily" /><meta
property="og:image" content="https://i1.wp.com/thezimbabwedaily.com/wp-content/uploads/2016/08/247WallSt.com-247WS-485073-newspapers-scaled.jpg?fit=1200%2C630&amp;ssl=1" /><meta
property="og:image:width" content="1200" /><meta
property="og:image:height" content="630" /><meta
property="og:locale" content="en_US" /><meta
name="twitter:creator" content="@zimbabwedaily" /><meta
name="twitter:site" content="@zimbabwedaily" /><meta
name="twitter:text:title" content="President mourns national hero, Moyo" /><meta
name="twitter:image" content="https://i1.wp.com/thezimbabwedaily.com/wp-content/uploads/2016/08/247WallSt.com-247WS-485073-newspapers-scaled.jpg?fit=1200%2C630&#038;ssl=1&#038;w=640" /><meta
name="twitter:card" content="summary_large_image" /> <script>var tdBlocksArray=[];function tdBlock(){this.id='';this.block_type=1;this.atts='';this.td_column_number='';this.td_current_page=1;this.post_count=0;this.found_posts=0;this.max_num_pages=0;this.td_filter_value='';this.is_ajax_running=!1;this.td_user_action='';this.header_color='';this.ajax_pagination_infinite_stop=''}(function(){var htmlTag=document.getElementsByTagName("html")[0];if(navigator.userAgent.indexOf("MSIE 10.0")>-1){htmlTag.className+=' ie10'}
if(!!navigator.userAgent.match(/Trident.*rv\:11\./)){htmlTag.className+=' ie11'}
if(navigator.userAgent.indexOf("Edge")>-1){htmlTag.className+=' ieEdge'}
if(/(iPad|iPhone|iPod)/g.test(navigator.userAgent)){htmlTag.className+=' td-md-is-ios'}
var user_agent=navigator.userAgent.toLowerCase();if(user_agent.indexOf("android")>-1){htmlTag.className+=' td-md-is-android'}
if(-1!==navigator.userAgent.indexOf('Mac OS X')){htmlTag.className+=' td-md-is-os-x'}
if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){htmlTag.className+=' td-md-is-chrome'}
if(-1!==navigator.userAgent.indexOf('Firefox')){htmlTag.className+=' td-md-is-firefox'}
if(-1!==navigator.userAgent.indexOf('Safari')&&-1===navigator.userAgent.indexOf('Chrome')){htmlTag.className+=' td-md-is-safari'}
if(-1!==navigator.userAgent.indexOf('IEMobile')){htmlTag.className+=' td-md-is-iemobile'}})();var tdLocalCache={};(function(){"use strict";tdLocalCache={data:{},remove:function(resource_id){delete tdLocalCache.data[resource_id]},exist:function(resource_id){return tdLocalCache.data.hasOwnProperty(resource_id)&&tdLocalCache.data[resource_id]!==null},get:function(resource_id){return tdLocalCache.data[resource_id]},set:function(resource_id,cachedData){tdLocalCache.remove(resource_id);tdLocalCache.data[resource_id]=cachedData}}})();var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];var td_animation_stack_effect="type0";var tds_animation_stack=!0;var td_animation_stack_specific_selectors=".entry-thumb, img";var td_animation_stack_general_selectors=".td-animation-stack img, .td-animation-stack .entry-thumb, .post img";var tds_general_modal_image="yes";var tdc_is_installed="yes";var td_ajax_url="https:\/\/thezimbabwedaily.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=10.3.9.1";var td_get_template_directory_uri="https:\/\/thezimbabwedaily.com\/wp-content\/plugins\/td-composer\/legacy\/common";var tds_snap_menu="snap";var tds_logo_on_sticky="show_header_logo";var tds_header_style="3";var td_please_wait="Please wait...";var td_email_user_pass_incorrect="User or password incorrect!";var td_email_user_incorrect="Email or username incorrect!";var td_email_incorrect="Email incorrect!";var tds_more_articles_on_post_enable="";var tds_more_articles_on_post_time_to_wait="1";var tds_more_articles_on_post_pages_distance_from_top=0;var tds_theme_color_site_wide="#ea1717";var tds_smart_sidebar="";var tdThemeName="Newspaper";var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";var td_magnific_popup_translation_tNext="Next (Right arrow key)";var td_magnific_popup_translation_tCounter="%curr% of %total%";var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";var tdBlockNonce="a954d1ae7d";var tdsDateFormat="jS F Y";var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};var td_ad_background_click_link="";var td_ad_background_click_target=""</script> <style>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</style><link
rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png?v=yyQPxKaq9d"><link
rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png?v=yyQPxKaq9d"><link
rel="icon" type="image/png" sizes="192x192" href="/android-chrome-192x192.png?v=yyQPxKaq9d"><link
rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png?v=yyQPxKaq9d"><link
rel="manifest" href="/site.webmanifest?v=yyQPxKaq9d"><link
rel="mask-icon" href="/safari-pinned-tab.svg?v=yyQPxKaq9d" color="#f73859"><link
rel="shortcut icon" href="/favicon.ico?v=yyQPxKaq9d"><meta
name="apple-mobile-web-app-title" content="Zimbabwe Daily"><meta
name="application-name" content="Zimbabwe Daily"><meta
name="msapplication-TileColor" content="#f73859"><meta
name="theme-color" content="#f73859"> <script data-ad-client="ca-pub-2891693655432889" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://thezimbabwedaily.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://thezimbabwedaily.com/category/news",
                    "name": "News"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html",
                    "name": "President mourns national hero, Moyo"                                
                }
            }    
        ]
    }
</script> <meta
name="pwaforwp" content="wordpress-plugin"/><meta
name="theme-color" content="#D5E0EB"><meta
name="apple-mobile-web-app-title" content="The Zimbabwe Daily"><meta
name="application-name" content="The Zimbabwe Daily"><meta
name="apple-mobile-web-app-capable" content="yes"><meta
name="apple-mobile-web-app-status-bar-style" content="default"><meta
name="mobile-web-app-capable" content="yes"><meta
name="apple-touch-fullscreen" content="YES"><link
rel="apple-touch-startup-image" href="https://thezimbabwedaily.com/android-chrome-192x192.png?v=yyQPxKaq9d"><link
rel="apple-touch-icon" sizes="192x192" href="https://thezimbabwedaily.com/android-chrome-192x192.png?v=yyQPxKaq9d"><link
rel="apple-touch-icon" sizes="512x512" href="https://thezimbabwedaily.com/android-chrome-512x512.png?v=yyQPxKaq9d"><style>.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,.tds-button2 .tdm-btn-text,.tds-button2 i,.tds-button5:hover .tdm-btn-text,.tds-button5:hover i,.tds-button6 .tdm-btn-text,.tds-button6 i,.tdm_block_list .tdm-list-item i,.tdm_block_pricing .tdm-pricing-feature i,.tdm-social-item i{color:#ea1717}.tds-button1,.tds-button6:after,.tds-title2 .tdm-title-line:after,.tds-title3 .tdm-title-line:after,.tdm_block_pricing.tdm-pricing-featured:before,.tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,.tds-progress-bar1 .tdm-progress-bar:after,.tds-progress-bar2 .tdm-progress-bar:after,.tds-social3 .tdm-social-item{background-color:#ea1717}.tds-button2:before,.tds-button6:before,.tds-progress-bar3 .tdm-progress-bar:after{border-color:#ea1717}.tdm-btn-style1{background-color:#ea1717}.tdm-btn-style2:before{border-color:#ea1717}.tdm-btn-style2{color:#ea1717}.tdm-btn-style3{-webkit-box-shadow:0 2px 16px #ea1717;-moz-box-shadow:0 2px 16px #ea1717;box-shadow:0 2px 16px #ea1717}.tdm-btn-style3:hover{-webkit-box-shadow:0 4px 26px #ea1717;-moz-box-shadow:0 4px 26px #ea1717;box-shadow:0 4px 26px #ea1717}</style><style id="tdw-css-placeholder"></style></head><body
class="post-template-default single single-post postid-529731 single-format-standard td-standard-pack president-mourns-national-hero-moyo global-block-template-1 single_template_12 td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div
class="td-scroll-up"><i
class="td-icon-menu-up"></i></div><div
class="td-menu-background"></div><div
id="td-mobile-nav"><div
class="td-mobile-container"><div
class="td-menu-socials-wrap"><div
class="td-menu-socials">
<span
class="td-social-icon-wrap">
<a
target="_blank" rel="nofollow" href="https://www.facebook.com/thezimbabwedaily" title="Facebook">
<i
class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span
class="td-social-icon-wrap">
<a
target="_blank" rel="nofollow" href="https://twitter.com/zimbabwedaily" title="Twitter">
<i
class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div
class="td-mobile-close">
<a
href="#"><i
class="td-icon-close-mobile"></i></a></div></div><div
class="td-menu-login-section"><div
class="td-guest-wrap"><div
class="td-menu-login"><a
id="login-link-mob">Sign in</a></div></div></div><div
class="td-mobile-content"><div
class="menu-main-menu-container"><ul
id="menu-main-menu" class="td-mobile-main-menu"><li
id="menu-item-108531" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-108531"><a
href="https://thezimbabwedaily.com/">Home</a></li><li
id="menu-item-108532" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108532"><a
href="https://thezimbabwedaily.com/about-us">About Us</a></li><li
id="menu-item-108533" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108533"><a
href="https://thezimbabwedaily.com/advertising">Advertising</a></li><li
id="menu-item-108534" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108534"><a
href="https://thezimbabwedaily.com/submit-a-story-or-opinion">Submit a story or opinion</a></li><li
id="menu-item-272887" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-272887"><a
href="https://thezimbabwedaily.com/privacy">Privacy</a></li></ul></div></div></div><div
id="login-form-mobile" class="td-register-section"><div
id="td-login-mob" class="td-login-animation td-login-hide-mob"><div
class="td-login-close">
<a
href="#" class="td-back-button"><i
class="td-icon-read-down"></i></a><div
class="td-login-title">Sign in</div><div
class="td-mobile-close">
<a
href="#"><i
class="td-icon-close-mobile"></i></a></div></div><div
class="td-login-form-wrap"><div
class="td-login-panel-title"><span>Welcome!</span>Log into your account</div><div
class="td_display_err"></div><div
class="td-login-inputs"><input
class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div><div
class="td-login-inputs"><input
class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
<input
type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN"><div
class="td-login-info-text">
<a
href="#" id="forgot-pass-link-mob">Forgot your password?</a></div><div
class="td-login-register-link"></div></div></div><div
id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob"><div
class="td-forgot-pass-close">
<a
href="#" class="td-back-button"><i
class="td-icon-read-down"></i></a><div
class="td-login-title">Password recovery</div></div><div
class="td-login-form-wrap"><div
class="td-login-panel-title">Recover your password</div><div
class="td_display_err"></div><div
class="td-login-inputs"><input
class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
<input
type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass"></div></div></div></div><div
class="td-search-background"></div><div
class="td-search-wrap-mob"><div
class="td-drop-down-search"><form
method="get" class="td-search-form" action="https://thezimbabwedaily.com/"><div
class="td-search-close">
<a
href="#"><i
class="td-icon-close-mobile"></i></a></div><div
role="search" class="td-search-input">
<span>Search</span>
<input
id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div
id="td-aj-search-mob" class="td-ajax-search-flex"></div></div></div><div
id="td-outer-wrap" class="td-theme-wrap"><div
class="tdc-header-wrap "><div
class="td-header-wrap td-header-style-3 "><div
class="td-header-top-menu-full td-container-wrap td_stretch_container td_stretch_content_1200"><div
class="td-container td-header-row td-header-top-menu"><div
class="top-bar-style-mp-1"><div
class="td-header-sp-top-widget"><div
class="td-search-btns-wrap">
<a
id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i
class="td-icon-search"></i></a></div><div
class="td-drop-down-search" aria-labelledby="td-header-search-button"><form
method="get" class="td-search-form" action="https://thezimbabwedaily.com/"><div
role="search" class="td-head-form-search-wrap">
<input
id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input
class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div
id="td-aj-search"></div></div></div><div
class="td-header-sp-top-menu"><div
class="td-weather-top-widget" id="td_top_weather_uid">
<i
class="td-icons rain-n"></i><div
class="td-weather-now" data-block-uid="td_top_weather_uid">
<span
class="td-big-degrees">18.3</span>
<span
class="td-weather-unit">C</span></div><div
class="td-weather-header"><div
class="td-weather-city">Harare</div></div></div><div
class="td_data_time"><div
style="visibility:hidden;">12th January 2021</div></div><ul
class="top-header-menu td_ul_login"><li
class="menu-item"><a
class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span
class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul></div><div
class="td-header-sp-phone">
<span>Tel:</span> <a
href="tel:+263 78 6729125">+263 78 6729125</a></div><div
class="td-header-sp-email">
<span>Email:</span> <a
href="mailto:info@thezimbabwedaily.com">info@thezimbabwedaily.com</a></div><div
class="td-header-sp-info">
International: +1 724 726 1658</div></div><div
id="login-form" class="white-popup-block mfp-hide mfp-with-anim"><div
class="td-login-wrap">
<a
href="#" class="td-back-button"><i
class="td-icon-modal-back"></i></a><div
id="td-login-div" class="td-login-form-div td-display-block"><div
class="td-login-panel-title">Sign in</div><div
class="td-login-panel-descr">Welcome! Log into your account</div><div
class="td_display_err"></div><div
class="td-login-inputs"><input
class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div><div
class="td-login-inputs"><input
class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
<input
type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login"><div
class="td-login-info-text"><a
href="#" id="forgot-pass-link">Forgot your password? Get help</a></div></div><div
id="td-forgot-pass-div" class="td-login-form-div td-display-none"><div
class="td-login-panel-title">Password recovery</div><div
class="td-login-panel-descr">Recover your password</div><div
class="td_display_err"></div><div
class="td-login-inputs"><input
class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
<input
type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password"><div
class="td-login-info-text">A password will be e-mailed to you.</div></div></div></div></div></div><div
class="td-banner-wrap-full td-container-wrap td_stretch_container td_stretch_content_1200"><div
class="td-container td-header-row td-header-header"><div
class="td-header-sp-logo">
<a
class="td-main-logo" href="https://thezimbabwedaily.com/">
<img
class="td-retina-data" data-retina="https://www.thezimbabwedaily.com/Logo%20[2]%20-%20cropped.svg" src="https://www.thezimbabwedaily.com/Logo%20[2]%20-%20cropped.svg" alt=""/>
<span
class="td-visual-hidden">The Zimbabwe Daily</span>
</a></div><div
class="td-header-sp-recs"><div
class="td-header-rec-wrap">
 <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div
class="td-g-rec td-g-rec-id-header tdi_1_b05 td_block_template_1 "><style>.tdi_1_b05.td-a-rec{text-align:center}.tdi_1_b05 .td-element-style{z-index:-1}.tdi_1_b05.td-a-rec-img{text-align:left}.tdi_1_b05.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_1_b05.td-a-rec-img{text-align:center}}</style><script type="text/javascript">var td_screen_width=window.innerWidth;if(td_screen_width>=1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-2891693655432889" data-ad-slot="4829232824"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({})}
if(td_screen_width>=1019&&td_screen_width<1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2891693655432889" data-ad-slot="4829232824"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({})}
if(td_screen_width>=768&&td_screen_width<1019){document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2891693655432889" data-ad-slot="4829232824"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({})}
if(td_screen_width<768){document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-2891693655432889" data-ad-slot="4829232824"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({})}</script> </div></div></div></div></div><div
class="td-header-menu-wrap-full td-container-wrap td_stretch_container td_stretch_content_1200"><div
class="td-header-menu-wrap td-header-menu-no-search"><div
class="td-container td-header-row td-header-main-menu black-menu"><div
id="td-header-menu" role="navigation"><div
id="td-top-mobile-toggle"><a
href="#"><i
class="td-icon-font td-icon-mobile"></i></a></div><div
class="td-main-menu-logo td-logo-in-header">
<a
class="td-mobile-logo td-sticky-header" href="https://thezimbabwedaily.com/">
<img
class="td-retina-data" data-retina="https://www.thezimbabwedaily.com/Logo%20[2]%20-%20cropped.svg" src="https://www.thezimbabwedaily.com/Logo%20[2]%20-%20cropped.svg" alt=""/>
</a>
<a
class="td-header-logo td-sticky-header" href="https://thezimbabwedaily.com/">
<img
class="td-retina-data" data-retina="https://www.thezimbabwedaily.com/Logo%20[2]%20-%20cropped.svg" src="https://www.thezimbabwedaily.com/Logo%20[2]%20-%20cropped.svg" alt=""/>
</a></div><div
class="menu-main-menu-container"><ul
id="menu-main-menu-1" class="sf-menu"><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-108531"><a
href="https://thezimbabwedaily.com/">Home</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-108532"><a
href="https://thezimbabwedaily.com/about-us">About Us</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-108533"><a
href="https://thezimbabwedaily.com/advertising">Advertising</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-108534"><a
href="https://thezimbabwedaily.com/submit-a-story-or-opinion">Submit a story or opinion</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-272887"><a
href="https://thezimbabwedaily.com/privacy">Privacy</a></li></ul></div></div><div
class="td-header-menu-social">
<span
class="td-social-icon-wrap">
<a
target="_blank" rel="nofollow" href="https://www.facebook.com/thezimbabwedaily" title="Facebook">
<i
class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span
class="td-social-icon-wrap">
<a
target="_blank" rel="nofollow" href="https://twitter.com/zimbabwedaily" title="Twitter">
<i
class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div
class="td-search-wrapper"><div
id="td-top-search"><div
class="header-search-wrap"><div
class="dropdown header-search">
<a
id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i
class="td-icon-search"></i></a></div></div></div></div></div></div></div></div></div><div
class="td-main-content-wrap td-container-wrap"><div
class="td-container td-post-template-12"><article
id="post-529731" class="post-529731 post type-post status-publish format-standard has-post-thumbnail category-news" itemscope itemtype="https://schema.org/Article"><div
class="td-pb-row"><div
class="td-pb-span12"><div
class="td-post-header"><div
class="td-crumb-container"><div
class="entry-crumbs"><span><a
title="" class="entry-crumb" href="https://thezimbabwedaily.com/">Home</a></span> <i
class="td-icon-right td-bread-sep"></i> <span><a
title="View all posts in News" class="entry-crumb" href="https://thezimbabwedaily.com/category/news">News</a></span> <i
class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span
class="td-bred-no-url-last">President mourns national hero, Moyo</span></div></div><header
class="td-post-title"><h1 class="entry-title">President mourns national hero, Moyo</h1><div
class="td-module-meta-info">
<span
class="td-post-date"><time
class="entry-date updated td-module-date" datetime="2021-01-12T22:07:19+00:00" >12th January 2021</time></span></div></header></div></div></div><div
class="td-pb-row"><div
class="td-pb-span8 td-main-content" role="main"><div
class="td-ss-main-content"><div
class="td-post-content tagdiv-type"><div
class="td-a-rec td-a-rec-id-content_top  tdi_4_5ac td_block_template_1"><style>.tdi_4_5ac.td-a-rec{text-align:center}.tdi_4_5ac .td-element-style{z-index:-1}.tdi_4_5ac.td-a-rec-img{text-align:left}.tdi_4_5ac.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_4_5ac.td-a-rec-img{text-align:center}}</style><script id="mNCC" language="javascript">medianet_width="728";medianet_height="90";medianet_crid="307870355";medianet_versionId="111299";(function(){var isSSL='https:'==document.location.protocol;var mnSrc=(isSSL?'https:':'http:')+'//contextual.media.net/nmedianet.js?cid=8CUSRHO4H'+(isSSL?'&https=1':'');document.write('<scr'+'ipt type="text/javascript" id="mNSC" src="'+mnSrc+'"></scr'+'ipt>')})()</script></div><p><strong>Joseph Madzimure, Harare Bureau</strong><br
/>President Mnangagwa has described the late Brigadier-General Collin Moyo (Retired), who died last Friday and was buried yesterday at the National Heroes Acre in Harare, as a brilliant military instructor, who trained many cadres during the liberation war, including the current commander of the Zimbabwe Defence Forces.</p><p>President Mnangagwa said Brig-Gen Moyo’s contribution to the liberation struggle was recorded in the annals of the country’s history, including as a military instructor at Morogoro Training Camp in Tanzania between 1973 and 1976.</p><p>“I received news of the untimely death on Friday of Brigadier General (Retired) Collin Moyo at the Haematology Centre in Harare with great sadness and a deep sense of loss.</p><p>“His passing on has created a deep void in our midst, especially among those of us who lived and fought alongside him during the period of our armed liberation struggle. We never expected that his illness was life-threatening to the extent that he would leave us so soon.</p><div
class="sirius-dfp-inarticle"><ins
class="adsbygoogle" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-7429385817508822" data-ad-slot="2152224461"></ins></div><p>“The late Brigadier General Moyo, also known by his Chimurenga name as Rodwell Nyika, was a veteran of the armed liberation struggle who joined other revolutionary Zipra cadres in Zambia at a very tender age. In that role, he trained many cadres, including the current Commander Defence Forces, General Philip Valerio Sibanda,” said President Mnangagwa.</p>
 <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div
class="td-g-rec td-g-rec-id-content_inline tdi_3_efb td_block_template_1 "><style>.tdi_3_efb.td-a-rec{text-align:center}.tdi_3_efb .td-element-style{z-index:-1}.tdi_3_efb.td-a-rec-img{text-align:left}.tdi_3_efb.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_3_efb.td-a-rec-img{text-align:center}}</style><script type="text/javascript">var td_screen_width=window.innerWidth;if(td_screen_width>=1140){document.write('<span class="td-adspot-title">- Advertisement - </span><ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2891693655432889" data-ad-slot="7767731863"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({})}
if(td_screen_width>=1019&&td_screen_width<1140){document.write('<span class="td-adspot-title">- Advertisement - </span><ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2891693655432889" data-ad-slot="7767731863"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({})}
if(td_screen_width>=768&&td_screen_width<1019){document.write('<span class="td-adspot-title">- Advertisement - </span><ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2891693655432889" data-ad-slot="7767731863"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({})}
if(td_screen_width<768){document.write('<span class="td-adspot-title">- Advertisement - </span><ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-2891693655432889" data-ad-slot="7767731863"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({})}</script> </div><p>He said apart from being a brilliant military instructor, the late Brig-Gen Moyo would also be remembered for forging the unity of fighters across the then political divide.</p><p>Brig-Gen Moyo did not only realise the wisdom of the strength in numbers, but also that the liberation struggle was national in character, whose main goal beyond political independence was the establishment of a unitary state of Zimbabwe which would be home to all Zimbabweans regardless of tribe, colour, creed or political affiliation.</p><p>“On behalf of the party, Zanu-PF, Government, the people of Zimbabwe, my family, and indeed on my own behalf, I wish to convey my heartfelt condolences to the Moyo family, especially to his wife and the children, who have lost a loving husband, father and pillar of strength.</p><div
class="sirius-dfp-inarticle"><ins
class="adsbygoogle" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-7429385817508822" data-ad-slot="7815614683"></ins></div><p>“May they take comfort from the knowledge that we are together during this their darkest hour of grief,” said President Mnangagwa.</p><p>Brig-Gen Moyo’s burial was attended by few family members, friends and Government officials in keeping with Covid-19 control regulations to avoid the spread of the pandemic.</p><p>Speaking during the burial of the late national hero, Acting President Kembo Mohadi described Brig-Gen Moyo as a decorated military commander who dedicated his life to liberate the country from the yoke of colonial bondage.</p><p>“Death has robbed us of an outstanding soldier, a leader, an inspiring instructor who was instrumental in moulding some of the war veterans and soldiers who are still active in Zimbabwe today. He was a fountain of knowledge grounded in sound political philosophy. Many of us remain with fond memories of his instructive wisdom,” said Acting President Mohadi.</p><p>Acting President Mohadi warned the public against complacence as Covid-19 cases are increasing saying the second wave of the lethal viral infection threatens the core of the productive sector.</p><p>“As the nation mourns this National Hero, we are faced with a deadly and silent killer Covid-19 which also robbed many families across the nation of a father, brother, sister, mother, daughter or son. This second wave of the lethal viral infection threatens the very core of our nation’s productivity.</p><div
class="sirius-dfp-inarticle"><ins
class="adsbygoogle" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-7429385817508822" data-ad-slot="7019723555"></ins></div><p>“Whilst the late Brigadier General Moyo did not die of Covid-19, we nonetheless are cognisant, as a nation of the importance of the prevention of the spread of this virus by strict observance of the restriction regulations and the World Health Organisation protocols of frequent hand washing with soap or sanitise, proper wearing of masks, social distancing and staying at home unless it is absolutely imperative for one to leave their home,”.</p><p>Turning to the quest for economic emancipation, he said as the country embark on the National Development Strategy 1, it is incumbent to take a leaf from such as cadres like the late Brigadier General Moyo.</p><p>This economic war, he said, needs no guns but a people with focused, transformative, diligent and productive mind.</p><p>“Armed with a positive, winning mind-set we can make the economy tick once again. As Zimbabwe moves into the practical implementation of the NDS1, we seek to put into practical form that which we learn.</p><p>“This is why our universities are moving towards the industrialisation and transformation of our communities. The late Cde Moyo like many of us who went through the training, did not learn for the sake of learning. We acquired knowledge and skills so that we may win the independence of our nation,” said Acting President Mohadi.</p><p>He encouraged youths to make of use of education to produce an economy, an industry and shape the future livelihoods for prosperity.</p><p>He further said the desire of the Second Republic is to build and transform the economic and social landscape of Zimbabwe.</p><p>“We must never lose our focus from creating a prosperous Zimbabwe as guided by our national collective vision that leads us to vision 2030. We should not give up. Our gallant freedom fighters did not give up during the bombings and attacks of the enemy. We need to continue to fight to better the lives of our people,” he said.</p><div
class="sirius-dfp-inarticle"><ins
class="adsbygoogle" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-7429385817508822" data-ad-slot="1609298988"></ins></div><p>He said that the nation was losing the founding crop of veterans of the armed struggle.</p><p>“These men and women leave behind them an illustrious trail of gallant efforts made to win us the freedom we now enjoy. We gather at this sacred shrine to not only inter his remains, but certainly to mourn, celebrate, cherish and express our eternal gratitude to his contribution to the liberation of our nation Zimbabwe.</p><p>“Fellow compatriots, death has robbed us of an outstanding soldier, a leader, an inspiring instructor who was instrumental in moulding some of the war veterans and soldiers who are still active in Zimbabwe today,” said Acting President Mohadi.</p><p>He described the late national hero as a fountain of knowledge grounded in sound political philosophy.</p><p>“Many of us remain with fond memories of his instructive wisdom,” he said.</p><p>Acting President Mohadi was accompanied by Vice-President Costantino Chiwenga, Minister of Defence and War Veterans Affairs Oppah Muchinguri-Kashiri, Minister of Home Affairs and Cultural Heritage Kazembe-Kazembe, service chiefs and senior Government officials.</p><div
class="sirius-dfp-inarticle"><ins
class="adsbygoogle" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-7429385817508822" data-ad-slot="2730808969"></ins></div><p>Brig-Gen Moyo (Rtd) was born on July 23, 1954 in Mberengwa, Midlands Province, under Chief Mapiravana.<br
/>He was the second child in a family of 10 and attended several primary schools in Mberengwa before doing O-level at Chegato Secondary School in the district.</p><p>He grew up in a village environment and as a result of his upbringing, he became conscious of political injustices and that compelled him to join the liberation struggle at 18.</p><p>In July 1972, the he joined the liberation struggle in Zambia after going through Botswana.</p><p>In Zambia, he and others were met by Zipra leaders such as Cdes Jason Ziyaphapha Moyo, Alfred Nikita Mangena, Elliot Maseko and Ambrose Mutinhiri who facilitated their movement to Morogoro in Tanzania for military training.</p><p>In early 1973, he started training with 83 others under the commander of the training camp Cde Sam Mfakazi and instructors, Cdes Jevan Maseko, Gedi Dube, Dubu Nleya and Stanley Gagisa.</p><p>They went through a six-month semi-commando course covering all aspects of guerrilla warfare.</p><div
class="sirius-dfp-inarticle"><ins
class="adsbygoogle" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-7429385817508822" data-ad-slot="3491542086"></ins></div><p>During the course, he was chosen to attend the Zipra Conference of Militants at Zambia’s Mwembeshi Camp.</p><p>Brig-Gen Moyo (Rtd) was instrumental in the training of over 5 000 recruits at Morogoro Training Camp between 1973 and 1976.</p><p>When the Zimbabwe People’s Army (Zipa) was formed in 1975, he was heavily involved in some joint training among Zipra, Zanla and ANC cadres and his contribution was invaluable.</p><p>Zanla recruits and instructors were from Mgagao and some ANC recruits came from Mbagala and Dar-es-Salaam.<br
/>During the joint training, he worked together with Zanla instructors such as the current Vice-President Constatino Chiwenga, former Commissioner of Police Augustine Chihuri and the late Major General Amoth Chingombe, Comrade Dewetewe, Cde Mhuru, Cde Bastern Beta, Cde Liabizva Kuhondo, Cde Grey Tichatonga and others.</p><p>He also trained Zipra comrades such as General P.V Sibanda, the current Commander Defence Forces, Major General Diye, Major General N Dube, Lieutenant General S B Moyo (Rtd), Major General Chiramba and others.</p><p>The training team recorded some successes up until some disturbances which led to the closure of Morogoro Camp and the setting up of the new training camp at Chakwenga.</p><p>In early 1976, Bri-Gen Moyo was selected to go on a special course in the then Soviet Union leading a group of 200 combatants.</p><p>He went to Moscow and later to Sinferopol in Ukraine for further training.</p><p>The late Brig-Gen Moyo returned to Zambia at the end of 1976 and briefly stayed at Freedom Camp from where he was deployed to Feira Luwangwa area as a regional commander.</p><p>He shared operations with Zanla Forces in such areas as Kanyemba, Chidodo, Mashumbi Pools, Chikafa, Mahuwe and Bakasa.</p><p>He also operated in Kachuta, Doma, Rafingora, Mhangura, Mutorashanga, Vhuti, Kazangarare, Miami, Chindu and Karuru areas. His mission was to plan and conduct war operations and to destroy all enemy infrastructure in the area of responsibility.</p><p>At one point half of the country was under his command and as commander northern front, his area of responsibility covered three provinces which were Mashonaland Central, Mashonaland West and Matebeleland North stretching along the Zambezi River from Kazungula, Victoria Falls, Kariba Dam, Chirundu up to Kanyemba.</p><p>He commanded more than ten thousand armed men and women from his headquarters at the town of Kapfuwe in Zambia.</p><p>Under him were three regional commanders who waged the struggle until Independence. The late General commanded the Kavalamanja-Karoro Battle which the Zambians called “Nkondoyamukwezvalamba”.</p><p>The battle took place at Kavalamanja village about 30km from Feira along the Zambezi River. The battle was carried out by a combination of ground troops, paratroopers and aircraft. The battle lasted for four days with casualties on both sides.</p><p>He also masterminded the attack of Mana Pools Camp by Zipra forces. It was a well planned operation that was conducted by Zipra forces at night and the camp was overrun with many casualties on the enemy</p><p>At ceasefire time Zipra created a reserve force of about a brigade which remained in Zambia. This brigade was part of a contingency plan against the Rhodesians in case things went wrong during the ceasefire period.</p><p>The brigade however, later went into PAPA assembly point where he was the commander.</p><p>At Independence, the late General was attested into the Zimbabwe National Army and was attached to Headquarters 4 Infantry Brigade as a green board officer together with Air Vice Marshal Henry Muchena, the late Air Chief Marshal Perrance Shiri and Brigadier Gen Abel Mazinyane, Lt Col M Mpofu and Comrade Deny Murimo. He was commissioned as a Lieutenant Colonel in 1982 after which he rose to colonel and Brigadier-General on retirement.</p><p>During his career he was deployed in Mozambique and Somalia as a military observer in 1992 and 1993 respectively and attended many military courses.</p><p>Brig-Gen Moyo is survived by his wife and six children.</p><div
class="sharedaddy sd-sharing-enabled"><div
class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div
class="sd-content"><ul><li
class="share-print"><a
rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html#print" target="_blank" title="Click to print"><span></span><span
class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li
class="share-email"><a
rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html?share=email" target="_blank" title="Click to email this to a friend"><span></span><span
class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li
class="share-jetpack-whatsapp"><a
rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span
class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li
class="share-twitter"><a
rel="nofollow noopener noreferrer" data-shared="sharing-twitter-529731" class="share-twitter sd-button share-icon no-text" href="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span
class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li
class="share-facebook"><a
rel="nofollow noopener noreferrer" data-shared="sharing-facebook-529731" class="share-facebook sd-button share-icon no-text" href="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span
class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li
class="share-pinterest"><a
rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-529731" class="share-pinterest sd-button share-icon no-text" href="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span
class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li
class="share-reddit"><a
rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span
class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li
class="share-tumblr"><a
rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span
class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li
class="share-pocket"><a
rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span
class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li
class="share-telegram"><a
rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span
class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li
class="share-skype"><a
rel="nofollow noopener noreferrer" data-shared="sharing-skype-529731" class="share-skype sd-button share-icon no-text" href="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html?share=skype" target="_blank" title="Click to share on Skype"><span></span><span
class="sharing-screen-reader-text">Click to share on Skype (Opens in new window)</span></a></li><li
class="share-end"></li></ul></div></div></div><div
class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-76468380-529731-5ffe2c2b0c2e2' data-src='https://widgets.wp.com/likes/#blog_id=76468380&amp;post_id=529731&amp;origin=thezimbabwedaily.com&amp;obj_id=76468380-529731-5ffe2c2b0c2e2' data-name='like-post-frame-76468380-529731-5ffe2c2b0c2e2'><h3 class="sd-title">Like this:</h3><div
class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span
class='button'><span>Like</span></span> <span
class="loading">Loading...</span></div><span
class='sd-text-color'></span><a
class='sd-link-color'></a></div><div
id='jp-relatedposts' class='jp-relatedposts' ><h3 class="jp-relatedposts-headline"><em>Related</em></h3></div>
 <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div
class="td-g-rec td-g-rec-id-content_bottom tdi_5_2de td_block_template_1 "><style>.tdi_5_2de.td-a-rec{text-align:center}.tdi_5_2de .td-element-style{z-index:-1}.tdi_5_2de.td-a-rec-img{text-align:left}.tdi_5_2de.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_5_2de.td-a-rec-img{text-align:center}}</style><script type="text/javascript">var td_screen_width=window.innerWidth;if(td_screen_width>=1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2891693655432889" data-ad-slot="6425047065"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({})}
if(td_screen_width>=1019&&td_screen_width<1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2891693655432889" data-ad-slot="6425047065"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({})}
if(td_screen_width>=768&&td_screen_width<1019){document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2891693655432889" data-ad-slot="6425047065"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({})}
if(td_screen_width<768){document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-2891693655432889" data-ad-slot="6425047065"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({})}</script> </div></div><footer><div
class="td-post-source-tags"></div><div
class="td-post-sharing-bottom"><div
id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 "><div
class="td-post-sharing-visible"><a
class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fthezimbabwedaily.com%2Fnews%2F529731-president-mourns-national-hero-moyo.html"><div
class="td-social-but-icon"><i
class="td-icon-facebook"></i></div><div
class="td-social-but-text">Facebook</div>
</a><a
class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=President+mourns+national+hero%2C+Moyo&url=https%3A%2F%2Fthezimbabwedaily.com%2Fnews%2F529731-president-mourns-national-hero-moyo.html&via=zimbabwedaily"><div
class="td-social-but-icon"><i
class="td-icon-twitter"></i></div><div
class="td-social-but-text">Twitter</div>
</a><a
class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=President+mourns+national+hero%2C+Moyo %0A%0A https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html"><div
class="td-social-but-icon"><i
class="td-icon-whatsapp"></i></div><div
class="td-social-but-text">WhatsApp</div>
</a><a
class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html&title=President+mourns+national+hero%2C+Moyo"><div
class="td-social-but-icon"><i
class="td-icon-linkedin"></i></div><div
class="td-social-but-text">Linkedin</div>
</a><a
class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html&title=President+mourns+national+hero%2C+Moyo"><div
class="td-social-but-icon"><i
class="td-icon-reddit"></i></div><div
class="td-social-but-text">ReddIt</div>
</a><a
class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="mailto:?subject=President mourns national hero, Moyo&body=https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html"><div
class="td-social-but-icon"><i
class="td-icon-mail"></i></div><div
class="td-social-but-text">Email</div>
</a><a
class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#"><div
class="td-social-but-icon"><i
class="td-icon-print"></i></div><div
class="td-social-but-text">Print</div>
</a></div><div
class="td-social-sharing-hidden"><ul
class="td-pulldown-filter-list"></ul><a
class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom"><div
class="td-social-but-icon"><i
class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div><div
class="td-author-name vcard author" style="display: none"><span
class="fn"><a
href="https://thezimbabwedaily.com/author/staff-reporter">Staff Reporter</a></span></div>	        <span
class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta
itemprop="name" content="Staff Reporter"></span><meta
itemprop="datePublished" content="2021-01-12T22:07:19+00:00"><meta
itemprop="dateModified" content="2021-01-12T23:09:20+00:00"><meta
itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html"/><span
class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span
class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta
itemprop="url" content="https://www.thezimbabwedaily.com/Logo%20[2]%20-%20cropped.svg"></span><meta
itemprop="name" content="The Zimbabwe Daily"></span><meta
itemprop="headline " content="President mourns national hero, Moyo"><span
class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta
itemprop="url" content="https://i1.wp.com/thezimbabwedaily.com/wp-content/uploads/2016/08/247WallSt.com-247WS-485073-newspapers-scaled.jpg?fit=2560%2C1344&ssl=1"><meta
itemprop="width" content="2560"><meta
itemprop="height" content="1344"></span></footer><div
class="td_block_wrap td_block_related_posts tdi_6_b05 td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_6_b05" ><script>var block_tdi_6_b05=new tdBlock();block_tdi_6_b05.id="tdi_6_b05";block_tdi_6_b05.atts='{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_6_b05","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":529731,"live_filter_cur_post_author":"1","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_6_b05","tdc_css_class_style":"tdi_6_b05_rand_style"}';block_tdi_6_b05.td_column_number="3";block_tdi_6_b05.block_type="td_block_related_posts";block_tdi_6_b05.post_count="6";block_tdi_6_b05.found_posts="33749";block_tdi_6_b05.header_color="";block_tdi_6_b05.ajax_pagination_infinite_stop="";block_tdi_6_b05.max_num_pages="5625";tdBlocksArray.push(block_tdi_6_b05)</script><h4 class="td-related-title td-block-title"><a
id="tdi_7_6f2" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_6_b05" href="#">RELATED ARTICLES</a><a
id="tdi_8_61e" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_6_b05" href="#">MORE FROM AUTHOR</a></h4><div
id=tdi_6_b05 class="td_block_inner"><div
class="td-related-row"><div
class="td-related-span4"><div
class="td_module_related_posts td-animation-stack td_mod_related_posts"><div
class="td-module-image"><div
class="td-module-thumb"><a
href="https://thezimbabwedaily.com/news/529729-rbz-clarifies-introduction-of-new-notes.html" rel="bookmark" class="td-image-wrap " title="RBZ clarifies introduction of new notes" ><img
class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="RBZ clarifies introduction of new notes" data-type="image_tag" data-img-url="https://i1.wp.com/thezimbabwedaily.com/wp-content/uploads/2016/08/247WallSt.com-247WS-485073-newspapers-scaled.jpg?resize=218%2C150&ssl=1"  width="218" height="150" /></a></div>                <a
href="https://thezimbabwedaily.com/category/news" class="td-post-category">News</a></div><div
class="item-details"><h3 class="entry-title td-module-title"><a
href="https://thezimbabwedaily.com/news/529729-rbz-clarifies-introduction-of-new-notes.html" rel="bookmark" title="RBZ clarifies introduction of new notes">RBZ clarifies introduction of new notes</a></h3></div></div></div><div
class="td-related-span4"><div
class="td_module_related_posts td-animation-stack td_mod_related_posts"><div
class="td-module-image"><div
class="td-module-thumb"><a
href="https://thezimbabwedaily.com/news/529727-just-in-panic-as-villagers-mistake-cheetahs-for-lions.html" rel="bookmark" class="td-image-wrap " title="JUST IN: Panic as villagers mistake cheetahs for lions" ><img
class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="JUST IN: Panic as villagers mistake cheetahs for lions" data-type="image_tag" data-img-url="https://i0.wp.com/thezimbabwedaily.com/wp-content/uploads/2020/03/cropped-herald_site_icon-32x32-1.png?resize=32%2C22&ssl=1"  width="32" height="22" /></a></div>                <a
href="https://thezimbabwedaily.com/category/news" class="td-post-category">News</a></div><div
class="item-details"><h3 class="entry-title td-module-title"><a
href="https://thezimbabwedaily.com/news/529727-just-in-panic-as-villagers-mistake-cheetahs-for-lions.html" rel="bookmark" title="JUST IN: Panic as villagers mistake cheetahs for lions">JUST IN: Panic as villagers mistake cheetahs for lions</a></h3></div></div></div><div
class="td-related-span4"><div
class="td_module_related_posts td-animation-stack td_mod_related_posts"><div
class="td-module-image"><div
class="td-module-thumb"><a
href="https://thezimbabwedaily.com/news/529714-zim-dollar-maintains-stability-after-first-auction-of-the-year.html" rel="bookmark" class="td-image-wrap " title="Zim dollar maintains stability after first auction of the year" ><img
class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Zim dollar maintains stability after first auction of the year" data-type="image_tag" data-img-url="https://i1.wp.com/thezimbabwedaily.com/wp-content/uploads/2016/08/247WallSt.com-247WS-485073-newspapers-scaled.jpg?resize=218%2C150&ssl=1"  width="218" height="150" /></a></div>                <a
href="https://thezimbabwedaily.com/category/news" class="td-post-category">News</a></div><div
class="item-details"><h3 class="entry-title td-module-title"><a
href="https://thezimbabwedaily.com/news/529714-zim-dollar-maintains-stability-after-first-auction-of-the-year.html" rel="bookmark" title="Zim dollar maintains stability after first auction of the year">Zim dollar maintains stability after first auction of the year</a></h3></div></div></div></div><div
class="td-related-row"><div
class="td-related-span4"><div
class="td_module_related_posts td-animation-stack td_mod_related_posts"><div
class="td-module-image"><div
class="td-module-thumb"><a
href="https://thezimbabwedaily.com/news/529696-nation-urged-to-emulate-resolve-of-freedom-fighters.html" rel="bookmark" class="td-image-wrap " title="Nation urged to emulate resolve of freedom fighters" ><img
class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Nation urged to emulate resolve of freedom fighters" data-type="image_tag" data-img-url="https://i1.wp.com/thezimbabwedaily.com/wp-content/uploads/2016/08/247WallSt.com-247WS-485073-newspapers-scaled.jpg?resize=218%2C150&ssl=1"  width="218" height="150" /></a></div>                <a
href="https://thezimbabwedaily.com/category/news" class="td-post-category">News</a></div><div
class="item-details"><h3 class="entry-title td-module-title"><a
href="https://thezimbabwedaily.com/news/529696-nation-urged-to-emulate-resolve-of-freedom-fighters.html" rel="bookmark" title="Nation urged to emulate resolve of freedom fighters">Nation urged to emulate resolve of freedom fighters</a></h3></div></div></div><div
class="td-related-span4"><div
class="td_module_related_posts td-animation-stack td_mod_related_posts"><div
class="td-module-image"><div
class="td-module-thumb"><a
href="https://thezimbabwedaily.com/news/529690-just-in-gweru-city-employees-hit-by-covid-19.html" rel="bookmark" class="td-image-wrap " title="JUST IN: Gweru City employees hit by Covid-19" ><img
class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="JUST IN: Gweru City employees hit by Covid-19" data-type="image_tag" data-img-url="https://i0.wp.com/thezimbabwedaily.com/wp-content/uploads/2020/03/cropped-herald_site_icon-32x32-1.png?resize=32%2C22&ssl=1"  width="32" height="22" /></a></div>                <a
href="https://thezimbabwedaily.com/category/news" class="td-post-category">News</a></div><div
class="item-details"><h3 class="entry-title td-module-title"><a
href="https://thezimbabwedaily.com/news/529690-just-in-gweru-city-employees-hit-by-covid-19.html" rel="bookmark" title="JUST IN: Gweru City employees hit by Covid-19">JUST IN: Gweru City employees hit by Covid-19</a></h3></div></div></div><div
class="td-related-span4"><div
class="td_module_related_posts td-animation-stack td_mod_related_posts"><div
class="td-module-image"><div
class="td-module-thumb"><a
href="https://thezimbabwedaily.com/news/529692-trump-dropped-by-biggest-lender-deutsche-bank-for-future-business-nyt.html" rel="bookmark" class="td-image-wrap " title="Trump dropped by biggest lender Deutsche Bank for future business: NYT" ><img
class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Trump dropped by biggest lender Deutsche Bank for future business: NYT" data-type="image_tag" data-img-url="https://i1.wp.com/thezimbabwedaily.com/wp-content/uploads/2021/01/trump.jpg?resize=218%2C150&ssl=1"  width="218" height="150" /></a></div>                <a
href="https://thezimbabwedaily.com/category/news" class="td-post-category">News</a></div><div
class="item-details"><h3 class="entry-title td-module-title"><a
href="https://thezimbabwedaily.com/news/529692-trump-dropped-by-biggest-lender-deutsche-bank-for-future-business-nyt.html" rel="bookmark" title="Trump dropped by biggest lender Deutsche Bank for future business: NYT">Trump dropped by biggest lender Deutsche Bank for future business: NYT</a></h3></div></div></div></div></div><div
class="td-next-prev-wrap"><a
href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_6_b05" data-td_block_id="tdi_6_b05"><i
class="td-icon-font td-icon-menu-left"></i></a><a
href="#"  class="td-ajax-next-page" id="next-page-tdi_6_b05" data-td_block_id="tdi_6_b05"><i
class="td-icon-font td-icon-menu-right"></i></a></div></div><div
id="disqus_thread"></div></div></div><div
class="td-pb-span4 td-main-sidebar" role="complementary"><div
class="td-ss-main-sidebar"><aside
id="recent-posts-5" class="td_block_template_1 widget recent-posts-5 widget_recent_entries"><h4 class="block-title"><span>Recent Posts</span></h4><ul><li>
<a
href="https://thezimbabwedaily.com/news/529731-president-mourns-national-hero-moyo.html" aria-current="page">President mourns national hero, Moyo</a>
<span
class="post-date">12th January 2021</span></li><li>
<a
href="https://thezimbabwedaily.com/news/529729-rbz-clarifies-introduction-of-new-notes.html">RBZ clarifies introduction of new notes</a>
<span
class="post-date">12th January 2021</span></li><li>
<a
href="https://thezimbabwedaily.com/news/529727-just-in-panic-as-villagers-mistake-cheetahs-for-lions.html">JUST IN: Panic as villagers mistake cheetahs for lions</a>
<span
class="post-date">12th January 2021</span></li><li>
<a
href="https://thezimbabwedaily.com/news/529714-zim-dollar-maintains-stability-after-first-auction-of-the-year.html">Zim dollar maintains stability after first auction of the year</a>
<span
class="post-date">12th January 2021</span></li><li>
<a
href="https://thezimbabwedaily.com/news/529696-nation-urged-to-emulate-resolve-of-freedom-fighters.html">Nation urged to emulate resolve of freedom fighters</a>
<span
class="post-date">12th January 2021</span></li><li>
<a
href="https://thezimbabwedaily.com/news/529690-just-in-gweru-city-employees-hit-by-covid-19.html">JUST IN: Gweru City employees hit by Covid-19</a>
<span
class="post-date">12th January 2021</span></li><li>
<a
href="https://thezimbabwedaily.com/news/529692-trump-dropped-by-biggest-lender-deutsche-bank-for-future-business-nyt.html">Trump dropped by biggest lender Deutsche Bank for future business: NYT</a>
<span
class="post-date">12th January 2021</span></li><li>
<a
href="https://thezimbabwedaily.com/news/529697-twitter-suspends-tens-of-thousands-of-accounts-dedicated-to-sharing-qanon-content.html">Twitter suspends tens of thousands of accounts dedicated to sharing QAnon content</a>
<span
class="post-date">12th January 2021</span></li><li>
<a
href="https://thezimbabwedaily.com/news/529686-kaizer-chiefs-star-khama-billiat-ruled-out-for-two-months.html">Kaizer Chiefs star Khama Billiat ruled out for two months</a>
<span
class="post-date">12th January 2021</span></li><li>
<a
href="https://thezimbabwedaily.com/news/529724-uganda-goes-to-the-polls-in-elections-marred-by-repression.html">Uganda goes to the polls in elections marred by repression</a>
<span
class="post-date">12th January 2021</span></li><li>
<a
href="https://thezimbabwedaily.com/news/529678-tendayi-darikwa-joins-wigan-athletic.html">Tendayi Darikwa joins Wigan Athletic</a>
<span
class="post-date">12th January 2021</span></li><li>
<a
href="https://thezimbabwedaily.com/news/529680-caf-reach-decision-on-celtics-cc-fate.html">Caf reach decision on Celtic’s CC fate</a>
<span
class="post-date">12th January 2021</span></li><li>
<a
href="https://thezimbabwedaily.com/news/529684-data-key-for-the-success-of-online-stores.html">Data key for the success of online stores</a>
<span
class="post-date">12th January 2021</span></li><li>
<a
href="https://thezimbabwedaily.com/news/529661-police-recover-two-drowned-bodies.html">Police recover two drowned bodies</a>
<span
class="post-date">12th January 2021</span></li><li>
<a
href="https://thezimbabwedaily.com/news/529663-harare-records-highest-number-of-covid-19-cases.html">Harare records highest number of Covid 19 cases</a>
<span
class="post-date">12th January 2021</span></li></ul></aside></div></div></div></article></div></div><div
class="tdc-footer-wrap "><div
class="td-footer-wrapper td-footer-container td-container-wrap td_stretch_container td_stretch_content_1200"><div
class="td-container"><div
class="td-pb-row"><div
class="td-pb-span12"></div></div><div
class="td-pb-row"><div
class="td-pb-span12"></div></div></div><div
class="td-footer-bottom-full"><div
class="td-container"><div
class="td-pb-row"><div
class="td-pb-span3"><aside
class="footer-logo-wrap"><a
href="https://thezimbabwedaily.com/"><img
class="td-retina-data" src="https://www.thezimbabwedaily.com/Logo%20[2]%20-%20cropped.svg" data-retina="https://www.thezimbabwedaily.com/Logo%20[2]%20-%20cropped.svg" alt="" title="" width="" /></a></aside></div><div
class="td-pb-span5"><aside
class="footer-text-wrap"><div
class="block-title"><span>ABOUT US</span></div><div
class="footer-email-wrap">Contact us: <a
href="mailto:info@thezimbabwedaily.com">info@thezimbabwedaily.com</a></div></aside></div><div
class="td-pb-span4"><aside
class="footer-social-wrap td-social-style-2"><div
class="block-title"><span>FOLLOW US</span></div>
<span
class="td-social-icon-wrap">
<a
target="_blank" rel="nofollow" href="https://www.facebook.com/thezimbabwedaily" title="Facebook">
<i
class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span
class="td-social-icon-wrap">
<a
target="_blank" rel="nofollow" href="https://twitter.com/zimbabwedaily" title="Twitter">
<i
class="td-icon-font td-icon-twitter"></i>
</a>
</span></aside></div></div></div></div></div><div
class="td-sub-footer-container td-container-wrap td_stretch_container td_stretch_content_1200"><div
class="td-container"><div
class="td-pb-row"><div
class="td-pb-span td-sub-footer-menu"><div
class="menu-main-menu-container"><ul
id="menu-main-menu-2" class="td-subfooter-menu"><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-108531"><a
href="https://thezimbabwedaily.com/">Home</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-108532"><a
href="https://thezimbabwedaily.com/about-us">About Us</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-108533"><a
href="https://thezimbabwedaily.com/advertising">Advertising</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-108534"><a
href="https://thezimbabwedaily.com/submit-a-story-or-opinion">Submit a story or opinion</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-272887"><a
href="https://thezimbabwedaily.com/privacy">Privacy</a></li></ul></div></div><div
class="td-pb-span td-sub-footer-copy">
&copy; The Zimbabwe Daily</div></div></div></div></div></div><div
id="nLXEbYCJzgXP" class="JKuMSuSkQPcI" style="background:#dddddd;z-index:9999999; "></div> <script type="text/javascript">var anOptions={"anOptionChoice":"2","anOptionStats":"1","anOptionAdsSelectors":"","anOptionCookie":"2","anOptionCookieLife":"30","anPageRedirect":"","anPermalink":"undefined","anOptionModalEffect":"fadeAndPop","anOptionModalspeed":"350","anOptionModalclose":!1,"anOptionModalOverlay":"rgba( 12,2,2,0.8 )","anAlternativeActivation":!1,"anAlternativeElement":"","anAlternativeText":"<p><strong>AdBlock detected!<\/strong><\/p>\n<p>Please add <a title=\"https:\/\/getadmiral.com?utm_medium=plugin&utm_campaign=abn&utm_source=abnlinks\" href=\"https:\/\/getadmiral.com?utm_medium=plugin&utm_campaign=abn&utm_source=abnlinks\" target=\"_blank\">www.getadmiral.com<\/a> to your adblocking whitelist or disable your adblocking software.<\/p>\n","anAlternativeClone":"2","anAlternativeProperties":"","anOptionModalShowAfter":0,"anPageMD5":"","anSiteID":0,"modalHTML":"<div class=\"JKuMSuSkQPcI-default\">\n\t<h1 style=\"\">Ad blocker detected! Please read this notice.<\/h1>\n\t<p>We've detected that you are using ad blocking software.<\/p>\n<p>The Zimbabwe Daily is a not for profit organisation and therefore relies on the income we generate from the adverts. We understand how annoying adverts can be, but we hope you will understand that without the income from adverts, we will not be able to provide the service that we provide to you free of charge.<\/p>\n<p><strong>Please add <a title=\"The Zimbabwe Daily\" href=\"http:\/\/www.thezimbabwedaily.com\" target=\"_blank\" rel=\"noopener\">www.thezimbabwedaily.com<\/a> to your ad blocking whitelist or disable your ad blocking software.<\/strong><\/p>\n<\/div>\n<a class=\"close-modal close-JKuMSuSkQPcI\">&#215;<\/a>"}</script><div
id="adsense" class="an-sponsored" style="position:absolute; z-index:-1; height:1px; width:1px; visibility: hidden; top: -1px; left: 0;"><img
class="an-advert-banner" alt="sponsored" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"></div><div
id="pwaforwp-add-to-home-click" style="background-color:#D5E0EB" class="pwaforwp-footer-prompt pwaforwp-bounceInUp pwaforwp-animated"> <span
id="pwaforwp-prompt-close" class="pwaforwp-prompt-close"></span><h3 style="color:#000">Add The Zimbabwe Daily to your Homescreen!</h3><div
style="background-color:#006dda; color:#fff" class="pwaforwp-btn pwaforwp-btn-add-to-home">Add</div></div> <script type="text/javascript">window.WPCOM_sharing_counts={"https:\/\/thezimbabwedaily.com\/news\/529731-president-mourns-national-hero-moyo.html":529731}</script> <div
id="sharing_email" style="display: none;"><form
action="/news/529731-president-mourns-national-hero-moyo.html" method="post">
<label
for="target_email">Send to Email Address</label>
<input
type="email" name="target_email" id="target_email" value="" />
<label
for="source_name">Your Name</label>
<input
type="text" name="source_name" id="source_name" value="" /><label
for="source_email">Your Email Address</label>
<input
type="email" name="source_email" id="source_email" value="" /><input
type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
<img
style="float: right; display: none" class="loading" src="https://thezimbabwedaily.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
<input
type="submit" value="Send Email" class="sharing_send" />
<a
rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a><div
class="errors errors-1" style="display: none;">
Post was not sent - check your email addresses!</div><div
class="errors errors-2" style="display: none;">
Email check failed, please try again</div><div
class="errors errors-3" style="display: none;">
Sorry, your blog cannot share posts by email.</div></form></div> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.2.1/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script> <script type='text/javascript' id='wpo_min-footer-1-js-extra'>var countVars={"disqusShortname":"zimbabwedaily"};var embedVars={"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"529731 https:\/\/thezimbabwedaily.com\/?p=529731","disqusShortname":"zimbabwedaily","disqusTitle":"President mourns national hero, Moyo","disqusUrl":"https:\/\/thezimbabwedaily.com\/news\/529731-president-mourns-national-hero-moyo.html","postId":"529731"}</script> <script type='text/javascript' src='https://thezimbabwedaily.com/wp-content/cache/wpo-minify/1608381520/assets/wpo-minify-footer-7f610a17.min.js' id='wpo_min-footer-1-js'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.6/wp-includes/js/underscore.min.js' id='underscore-js'></script> <script type='text/javascript' src='https://thezimbabwedaily.com/wp-content/cache/wpo-minify/1608381520/assets/wpo-minify-footer-d9ca0cf2.min.js' id='wpo_min-footer-3-js'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.6/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script> <script type='text/javascript' id='wpo_min-footer-5-js-extra'>var pnScriptSetting={"nonce":"3e65550623","pn_config":{"apiKey":"AIzaSyDhRbFy9m-NXZVkozYJwKdDYJuwsL6W_bw","authDomain":"pushnotificationsio.firebaseapp.com","databaseURL":"https:\/\/pushnotificationsio.firebaseio.com","projectId":"pushnotificationsio","storageBucket":"pushnotificationsio.appspot.com","messagingSenderId":"788493704860","appId":"1:788493704860:web:ba71fd692e7cc9651f5759","measurementId":"G-NXS0Z75BCH"},"swsource":"https:\/\/thezimbabwedaily.com\/?push_notification_sw=1","scope":"https:\/\/thezimbabwedaily.com\/","ajax_url":"https:\/\/thezimbabwedaily.com\/wp-admin\/admin-ajax.php"}</script> <script type='text/javascript' src='https://thezimbabwedaily.com/wp-content/cache/wpo-minify/1608381520/assets/wpo-minify-footer-cb8d17a3.min.js' id='wpo_min-footer-5-js'></script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js' id='pn-script-gtag-js'></script> <script type='text/javascript' id='pn-script-gtag-js-after'>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments)}gtag('js',new Date())</script> <script type='text/javascript' id='wpo_min-footer-7-js-extra'>var ajax_object={"nonce":"30ed6861f3","ajaxurl":"https:\/\/thezimbabwedaily.com\/wp-admin\/admin-ajax.php"}</script> <script type='text/javascript' src='https://thezimbabwedaily.com/wp-content/cache/wpo-minify/1608381520/assets/wpo-minify-footer-6d101e41.min.js' id='wpo_min-footer-7-js'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.6/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.2.1/_inc/build/postmessage.min.js' id='postmessage-js'></script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.2.1/_inc/build/jquery.jetpack-resize.min.js' id='jetpack_resize-js'></script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.2.1/_inc/build/likes/queuehandler.min.js' id='jetpack_likes_queuehandler-js'></script> <script type='text/javascript' id='sharing-js-js-extra'>var sharing_js_options={"lang":"en","counts":"1","is_stats_active":"1"}</script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.2.1/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script> <script type='text/javascript' id='sharing-js-js-after'>var windowOpen;jQuery(document.body).on('click','a.share-twitter',function(){if('undefined'!==typeof windowOpen){windowOpen.close()}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomtwitter','menubar=1,resizable=1,width=600,height=350');return!1});var windowOpen;jQuery(document.body).on('click','a.share-facebook',function(){if('undefined'!==typeof windowOpen){windowOpen.close()}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomfacebook','menubar=1,resizable=1,width=600,height=400');return!1});var windowOpen;jQuery(document.body).on('click','a.share-tumblr',function(){if('undefined'!==typeof windowOpen){windowOpen.close()}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomtumblr','menubar=1,resizable=1,width=450,height=450');return!1});var windowOpen;jQuery(document.body).on('click','a.share-pocket',function(){if('undefined'!==typeof windowOpen){windowOpen.close()}
windowOpen=window.open(jQuery(this).attr('href'),'wpcompocket','menubar=1,resizable=1,width=450,height=450');return!1});var windowOpen;jQuery(document.body).on('click','a.share-telegram',function(){if('undefined'!==typeof windowOpen){windowOpen.close()}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomtelegram','menubar=1,resizable=1,width=450,height=450');return!1});var windowOpen;jQuery(document.body).on('click','a.share-skype',function(){if('undefined'!==typeof windowOpen){windowOpen.close()}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomskype','menubar=1,resizable=1,width=305,height=665');return!1})</script> <iframe
src='https://widgets.wp.com/likes/master.html?ver=202102#ver=202102' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe><div
id='likes-other-gravatars'><div
class="likes-text"><span>%d</span> bloggers like this:</div><ul
class="wpl-avatars sd-like-gravatars"></ul></div><style>.pn-wrapper{box-shadow:0 1px 3px 0 rgba(60,64,67,.302),0 4px 8px 3px rgba(60,64,67,.149);font-family:Roboto,RobotoDraft,Helvetica,Arial,sans-serif;font-size:14px;align-items:center;background-color:#222;border:none;border-radius:4px;box-sizing:border-box;color:#fff;display:none;flex-wrap:wrap;font-weight:400;padding:16px 22px;z-index:99999;text-align:left;position:fixed;bottom:0;left:0;margin:20px;right:auto;top:auto}.pn-wrapper .pn-txt-wrap{display:flex;flex-wrap:wrap;position:relative;height:auto;line-height:1}.pn-wrapper .pn-btns{margin-left:10px;display:flex}.pn-wrapper .btn.act{color:#8ab4f8}.pn-wrapper .btn{align-items:center;border:none;display:inline-flex;outline:none;position:relative;font-size:14px;background:none;border-radius:4px;box-sizing:border-box;color:#5f6368;cursor:pointer;font-weight:500;outline:none;margin-left:8px;min-width:auto;padding:0 8px;text-decoration:none}</style><div
class="pn-wrapper">
<span
class="pn-txt-wrap">
<span
class="pn-msg">Enable Notifications</span>
<span
class="pn-btns">&nbsp;&nbsp;
<span
class="btn act" id="pn-activate-permission_link" tabindex="0" role="link" aria-label="ok link">
OK
</span>
<span
class="btn" id="pn-activate-permission_link_nothanks" tabindex="0" role="link" aria-label="no thanks link">
No thanks
</span>
</span>
</span></div> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-8945291-6"></script> <script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments)}
gtag('js',new Date());gtag('config','UA-8945291-6')</script>  <script>jQuery().ready(function(){tdWeather.addItem({"block_uid":"td_top_weather_uid","location":"Harare, ZW","api_location":"Harare","api_language":"en","api_key":"5f3ea4ec590758e4d191d6ea7aefa68d","today_icon":"rain-n","today_icon_text":"moderate rain","today_temp":[18.3,65],"today_humidity":92,"today_wind_speed":[0.5,0.3],"today_min":[18.3,65],"today_max":[18.3,65],"today_clouds":100,"current_unit":0,"forecast":[{"timestamp":1610485200,"day_name":"Tue","day_temp":[19,66],"owm_day_index":0},{"timestamp":1610496000,"day_name":"Wed","day_temp":[26,78],"owm_day_index":1},{"timestamp":1610582400,"day_name":"Thu","day_temp":[23,73],"owm_day_index":9},{"timestamp":1610668800,"day_name":"Fri","day_temp":[21,69],"owm_day_index":17},{"timestamp":1610755200,"day_name":"Sat","day_temp":[24,76],"owm_day_index":25},{"timestamp":1610841600,"day_name":"Sun","day_temp":[18,64],"owm_day_index":33}]})})</script> <script type='text/javascript' src='https://stats.wp.com/e-202102.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:9.2.1',blog:'76468380',post:'529731',tz:'0',srv:'thezimbabwedaily.com'}]);_stq.push(['clickTrackerInit','76468380','529731'])</script> </body></html>
<!-- Cached by WP-Optimize (gzip) - https://getwpo.com - Last modified: Tue, 12 Jan 2021 23:09:31 GMT -->
